メンバ募集!

ラストシューティングではいっしょにアプリ制作をするメンバを募集してます!
スキルアップを目的としたサークル活動の形です
各人のスキルを活かして、みなでアプリを創りストアに公開するまで行います
ご興味がある方はブログ横のFacebook・Google+のリンクやメールにて気軽にご連絡ください~ (・ω<)

ラベル

技術 (80) 開発 (77) ゲーム (67) アプリ (63) 福岡 (59) 趣味 (59) android (52) アニメ (22) レトロゲーム (21) 温故知新 (21) ガンダム (19) レポート (19) WEBサイト (17) 経済 (17) iOS (9) 麻雀 (7) グルメ (5) マンガ (4) Wear (1)

2014年7月30日水曜日

Android Studioで「INSTALL_FAILED_OLDER_SDK」エラー

Shunです。

世の中、手段と目的を履き違えることは多々あります。

大学で勉強するのはただの「手段」で「目的」じゃないですね。
目的は学んだ知識を使って収入を得ておまんまを食うことです。

ツールを使いこなすのはただの「手段」で「目的」じゃないですね。
目的はそのツール使いこなしてアプリなり作成して収入を得ておまんまを食うことです。

結局、何がしたいのか忘れないようにしたいものです。


閑話休題。

Android Studio、
Android WareなどGoogleの最新の技術を使うには都合が良さそう。
私も少し練習したりしてます。

そんななか、ちょっと作成したプロジェクトをRunすると
  Failure [INSTALL_FAILED_OLDER_SDK]
というエラーが表示されて端末側に作成したアプリが
インストールできない現象がでました。

そのときの対処の話をズラズラっと書きます。

INSTALL_FAILED_OLDER_SDKは
端末のandroidのバージョンと
プロジェクトをビルドするときのバージョンが違うことが問題っぽい。

プロジェクトのSettingsの中を見てみると
「Flavors」の「Target SDK Version」が"L"になってました。
最新バージョンの「Android L」でビルドする設定になっていた様子。
新規プロジェクトを作成時によくわからず設定したのかな?
(Lは下位バージョンと互換性がないのか?)

こいつをクリクリっと、、、あるぇー

で、これを"17"あたりにすれば大丈夫かなーとクリクリっと変える。
で、Run、、、またINSTALL_FAILED_OLDER_SDKエラー。。。

うーん、違うのかー?別の設定なのかー?
もう一度、Settingsを見ると、
あれ?「Target SDK Version」が"L"のままじゃん。

はい、ここを何度も変えても変わらないっす。
ええい!なんだこりゃ。
なんか壊れたのかなーと思ったり。

調べるとAndroid Studioは「build.gradle」というファイルが重要らしい。
見ると、
    compileSdkVersion 17
    buildToolsVersion '20.0.0'
    defaultConfig {
        applicationId 'com.example.shun.shuntest'
        minSdkVersion 17
        targetSdkVersion "L"
        versionCode 1
        versionName '1.0'
    }

という感じで、ビルドの設定が。
ここの
        targetSdkVersion "L"

        targetSdkVersion 17
にする。
(ここは20でもOKですね)

そしてRun、、、お、インストールされて端末側でアプリが動いた!
やったー!

。。。うん、Android Studioなかなか曲者ですね^^;